The following table shows the compatibility of Gerrit Code Review with Elasticsearch.

Elasticsearch Version Minimum Gerrit Version
2.4.x 2.14.8 or 2.15.3
5.6.x 2.14.8 or 2.15.3
6.2.x 2.14.8 or 2.15.3
6.3.x 2.14.10 or 2.15.3
6.4.x 2.14.12 or 2.15.4

Note that although Elasticsearch 2.4.x is supported, we do not recommend using such an old version.